Pairwise likelihood inference for mixed autoregressive ordinal probit models

Pairwise likelihood inference for mixed autoregressive ordinal probit models [R logo]

Help pages for package ‘maop’ version 0.2

maop | Mixed Autoregressive Ordered Probit Models
migraine | Longitudinal Study on Migraine Severity
print.maop | Mixed Autoregressive Ordered Probit Models
summary.maop | Mixed Autoregressive Ordered Probit Models


Mixed Autoregressive Ordered Probit Models

Description

Fits mixed autoregressive ordered probit models to a longitudinal data set by maximum pairwise likelihood.

Usage

maop(formula, subjects, periods=subjects, randomEffect=FALSE,
dynamics=NULL, startValues=NULL, distance=2, print.info=TRUE)

Arguments

formula | a formula expression of form response ~ predictors. The response must be an ordinal factor. The model fitted is a dynamic generalization of the ordered probit regression model and it must have an intercept. See the documentation of formula for other details.
subjects | identifier for the different subjects in the longitudinal study. This is a vector of the same length of the response containing identifiers for the different subjects. See the example.
periods | identifier for the different measurement periods of the subjects in the longitudinal study. The default value is equal to that of subjects assuming one single measurement period for each patient. Otherwise, periods is a vector of the same length of the response containing identifiers for the different measurement periods. See the example.
randomEffect | logical. Should a subject-specific random effect be included?
dynamics | a factor whose levels correspond to different autocorrelation parameters. The default value is NULL indicating an unique autocorrelation parameter.
startValues | starting values. The default value is NULL meaning that starting values are computed automatically by the maop function
distance | maximal distance within pairs of observations included in the pseudolikelihood.
print.info | logical. Should information about computation status be printed?.

Details

MAOP stands for mixed autoregressive ordered probit models, as described in Varin and Czado (2009). Model fitting is performed by maximum pairwise likelihood (Varin, 2008).

Value

An object of class maop. The components of an object of the class maop are

formula | fitted model.
subjects | factor denoting different subjects.
periods | factor denoting different measurement periods.
isRandomEffect | whether a subject-specific random effect is included in the model.
dynamics | factor denoting different autocorrelation parameters.
distance | maximal admissible distance between pairs of observations.
startValues | starting values.
coeff | maximum pairwise likelihood estimator.
stdErr | estimated standard errors.
varMatrix | estimated variance-covariance matrix of the parameter estimates.
logPair | maximized log-pairwise likelihood.
clic | composite likelihood information criterion (Varin and Vidoni, 2005).
convergence | integer code as in optim function.

Author(s)

Cristiano Varin

References

Varin, C. and Vidoni, P. (2005). A note on composite likelihood inference and model selection. Biometrika, 92, 519–528.

Varin, C. (2008). On composite marginal likelihoods. Advances in Statistical Analysis, 92, 1–28.

Varin, C. and Czado, C. (2009). A mixed autoregressive probit model for ordinal longitudinal data. Biostatistics, to appear.

See Also

migraine, optim, polr

Examples

# Fits a MAOP model to migraine data (Varin and Czado, 2009)
data(migraine)
attach(migraine)
# covariates
university <-rep(0,length(HA))
university[ED==5]<-1
university[ED==6]<-1
university[ED==7]<-1
university <- as.factor(university==1)
analgesics <- as.factor(MEDANALG=="Y")
# weather covariates
wc <- factor(cut(MINWC, breaks=c(-50, -10, 0, 10, 30)))
high.pressure <- PMN>10130
high.pressure.yesterday <- PMN1P>10130
change <- rep("persistence", length(high.pressure))
change[(!high.pressure & high.pressure.yesterday)] <- "worse"
change[(high.pressure & !high.pressure.yesterday)] <- "better"
change <- factor(change)
humidity <- cut(RHMN, breaks=c(0, 60, 80, 100))
# model
m <- HA~university+analgesics+wc+humidity+change
# fit model m with different autocorrelation parameters
# for patients with analgesics intake and those who not
# try with pairwise likelihood with maximal distance 2
maop2 <- maop(m, subjects=SUBJECT, periods=PERIOD, randomEffect=TRUE,
dynamics=analgesics, distance=2)
summary(maop2, digits=2)
# pairwise likelihood with maximal distance equals to 6
maop6 <- maop(m, subjects=SUBJECT, periods=PERIOD, randomEffect=TRUE,
dynamics=analgesics, distance=6, startValues=maop2$coeff)
summary(maop6, digits=2)
[Package maop version 0.2 Index]


Longitudinal Study on Migraine Severity

Description

Data on migraine severity in 119 Canadian (Toronto) patients

Usage

data(migraine)

Format

This data frame contains 16,366 rows and the following columns:

Responses

HA
headache severity: 0 absence, 1 mild, 2 moderate, 3 painful, 4 severe, 5 intense
Personal covariates
AGE
age of patient
ED
educational level: 1 less than highschool, 2 highschool, 3 trade or technical training, 4 community college, 5 BA, 6 MA, 7 PhD
EMPL
employment status: 1 full-time, 2 part-time, 3 on disability, 4 unemployed, 5 other
MARITAL
marital status: 1 single, 2 married, cohabitating, 3 separated, 4 divorced, 5 widowed
OCC
occupation: 1 professional/executive manager, 2 skilled worker, 3 clerical worker, 4 semi-skilled or un-skilled, 5 homemaker, 6 unemployed, 7 student, 8 retired
PERIOD
measurement period index: the numeric part correspond to SUBJECT while the following alphabetic part to the measurement period
SEX
gender: Male, Female
SMOKE
currently smokes cigarettes: Yes, No
SUBJECT
patient index
WEATHER
patient indication weather is a trigger for their headache: Yes, No
Clinical covariates
COPHYS
comorbid physical illness(es): Yes, No
COPSYC
comorbid psychological condition(s): Yes, No
HATYPE
headache type: 1 migraine without aura, 2 migraine with aura, 3 mixed migraine/tension headache
MEDANALG
current analgesic medication intake for headache: Yes, No
MEDNONHA
current medication taken for reason other than headache: Yes, No
MEDOTHER
current other medication intake for headache : Yes, No
MEDPROPH
current prophylactic medication intake for headache: Yes, No
NEO
neuroticism domain T score
YRSSUFF
years suffering from migraine
Calendar covariates
DAY
day on which headache was recorded
DATE
date on which headache was recorded
INTRADAY
moment of the day on which headache was recorded: AM, NOON, PM, BED
MONTH
month on which headache was recorded
SEASEQ
season - by equinoxes and solstices: SPR Spring, SUM Summer, FALL Fall, WINT Winter
SEASMET
season - metheorologist's version by month: SPR Spring, SUM Summer, FALL Fall, WINT Winter
WDAY
day of the week on which headache was recorded: MON Monday, TUES Tuesday, WED Wednesday, THUR Thursday, FRI Friday, SAT Saturday, SUN Sunday
YEAR
year on which headache was recorded
Weather covariates
AHDXD
humidity index based on the change since the day before
AQISTN
Air Quality Index Station (nine stations)
AQMAX
maximum AQI; day of measurement
AQMAX1P
maximum AQI; previous day
AWCHILLD
windchilld index based on the change since the day before
CA
cloud total amount (tenths); day of measurement
CA1P
cloud total amount (tenths); previous day
DHDX
the amount of humidity index above yesterday level
MAXHD
humidity index based on max. temp and humidity per 24 hours; day of measurement
MAXHD1P
humidity index based on max. temp and humidity per 24 hours; previous day
MINWC
windchilld based on min. temp and windspeed per hour; day of measurement
MINWC1P
windchilld based on min. temp and windspeed per hour; previous day
PMN
pressure - mean sea level (.01 kilopascals); day of measurement
PMN1P
pressure - mean sea level (.01 kilopascals); previous day
PMND
pressure - mean sea level (.01 kilopascals); change from previous day
PREC
precipitation total amount, snow and rain (.1mm); day of measurement
PREC1P
precipitation total amount, snow and rain (.1mm); previous day
RHMN
mean relative humidity (%); day of measurement
RHMN1P
mean relative humidity (%); previous day
S
sunshine total amount (hours); day of measurement
S1P
sunshine total amount (hours); previous day
THUN
thunderstorm total daily severity; day of measurement: 0 no thunderstorm, 1 thunderstorm
THUN1P
thunderstorm total daily severity; previous day: 0 no thunderstorm, 1 thunderstorm
TMN
mean temperature (degree Celsius); day of measurement
TMN1P
mean temperature (degree Celsius); previous day
TMND
mean tempertature (degree Celsius); change from previous day
WSMAX
maximum wind speed (km/hr); day of measurement
WSMAX1P
maximum wind speed (km/hr;, previous day)
WSTN
weather station (three weather)

Source

Dr. Tommy Kostecki-Dillon.

References

Varin, C. and Czado, C. (2009). A mixed autoregressive probit model for ordinal longitudinal data. Biostatistics, to appear.

See Also

maop

[Package maop version 0.2 Index]